<!DOCTYPE html>
<!--[if IE 7]>
<html id="ie7" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR LIVES” | Rabbi John Rosove&#039;s Blog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://rabbijohnrosove.blog/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://s2.wp.com/wp-content/themes/pub/chateau/js/html5.js" type="text/javascript"></script>
<![endif]-->
<meta name='robots' content='max-image-preview:large' />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//rabbijohnrosove.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; Feed" href="https://rabbijohnrosove.blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; Comments Feed" href="https://rabbijohnrosove.blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR&nbsp;LIVES” Comments Feed" href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1625065786h&ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNUltugzAQvFDNBlpF7UfVs9hm6zjxS34k8u27QBuRQEh/kGc9s56dBS6BSe8yugy2sGCK0i7BJUhvWbLaYL1DjUzpBdZlRp8wwRFz4PLERrSg/3FVISgwKrqJCOe2bbqmBVG06UEYPzYQkccKKVeD10baSVP64Z0EFnvN0aAdjcxAMLxiZAYVl7Wx2j2X090c34gemx+dzmbm1ZfMVNT9ne1/t4g8a6fSE7n0vzIKbUe59Trla5Gta2ebGjKnug18OfiGbPoThAgRU2L0tbpYlg8kXG56KkMoAuSBZ+TlwUwrRNrSRGbjk1ueFHpGU1Nq3t0A9m24jlvSiJSXoqMCYs3gIPqyn+2+e999vO7fuuMPeLYv7w==?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link rel='stylesheet' id='print-css-1-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='all-css-4-1' href='https://s1.wp.com/_static/??-eJxti0EKgCAQAD+ULUaJl+gtJqbG6opr9P3o0CHqNAzMwFmEpdxcbpAOUfDwMTMU4iY2NLECB1Nj9g97y9zB/8Vko0GB5Oktn6kFlxxDGMEjrQbvYEmzVHIclNZy2i9lFDfR?cssminify=yes' type='text/css' media='all' />
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"25064604","siteName":"Rabbi John Rosove's Blog","siteURL":"https:\/\/rabbijohnrosove.blog","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/chateau","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frabbijohnrosove.blog%252F2021%252F08%252F12%252Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%252F","themeURL":"","xhrURL":"https:\/\/rabbijohnrosove.blog\/wp-admin\/admin-ajax.php","nonce":"464f608afa","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"3f597c62e7\" \/>","referer":"https:\/\/rabbijohnrosove.blog\/2021\/08\/12\/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives\/","canFollow":"1","feedID":"119392947","statusMessage":"","customizeLink":"https:\/\/rabbijohnrosove.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Frabbijohnrosove.wordpress.com%2F2021%2F08%2F12%2Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%2F","postID":"8311","shortlink":"https:\/\/wp.me\/p1HarO-2a3","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/rabbijohnrosove.blog\/8311","statsLink":"https:\/\/wordpress.com\/stats\/post\/8311\/rabbijohnrosove.blog","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Chateau","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 336 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frabbijohnrosove.blog%252F2021%252F08%252F12%252Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%252F\">Log in now.<\/a>","stats":"Stats"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJyFzUEKwkAMheELmQ4qtboQz9LWWGaYJGOSQXt7KyjUlau3+D944VFgFHZkD8lCEXNCs37CJtkm/FaSIWaEaqgLYIfIN/m6yGOuV7Q3TPeKOn+moch/EVCctHdc49WzZoei8pyXdqHz9rDrTse2a/fpBYU+RvU='></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1625210320h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rabbijohnrosove.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/" />
<link rel='shortlink' href='https://wp.me/p1HarO-2a3' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Frabbijohnrosove.blog%2F2021%2F08%2F12%2Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Frabbijohnrosove.blog%2F2021%2F08%2F12%2Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR LIVES”" />
<meta property="og:url" content="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/" />
<meta property="og:description" content="A collection of twenty diverse essays by leading Reform rabbis, educators, and thinkers that highlight their personal encounters with God in everyday life.Note: The following is the press release f…" />
<meta property="article:published_time" content="2021-08-12T15:20:30+00:00" />
<meta property="article:modified_time" content="2021-08-12T15:32:36+00:00" />
<meta property="og:site_name" content="Rabbi John Rosove&#039;s Blog" />
<meta property="og:image" content="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg" />
<meta property="og:image:width" content="1827" />
<meta property="og:image:height" content="2774" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR&nbsp;LIVES”" />
<meta name="twitter:image" content="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://rabbijohnrosove.blog/?openidserver=1' />
<link rel='openid.delegate' href='https://rabbijohnrosove.blog/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://rabbijohnrosove.blog/osd.xml" title="Rabbi John Rosove&#039;s Blog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 0, tn: 'chateau', amp: false, siteid: 8982, blogid: 25064604, consent: __ATA_CC(), flag: 2 };
		</script>
		<script type="text/javascript">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</script><meta name="application-name" content="Rabbi John Rosove&#039;s Blog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://rabbijohnrosove.blog/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="A collection of twenty diverse essays by leading Reform rabbis, educators, and thinkers that highlight their personal encounters with God in everyday life.Note: The following is the press release for a wonderful new volume of personal reflections about the experience of God and the holy. I was one of the contributors and was asked as&hellip;" />
<link rel="amphtml" href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/amp/"></head>

<body class="post-template-default single single-post postid-8311 single-format-standard customizer-styles-applied two-column content-sidebar highlander-enabled highlander-light">
<div id="page" class="hfeed">
		<div id="page-inner">
		<header id="branding" role="banner">
			<nav id="menu" role="navigation">
				<ul class="menu clear-fix">
<li class="page_item page-item-2"><a href="https://rabbijohnrosove.blog/about/">About</a></li>
</ul>
			</nav><!-- end #menu -->

			<div id="main-title">
				<hgroup>
					<h1 id="site-title"><a href="https://rabbijohnrosove.blog/" title="Rabbi John Rosove&#039;s Blog" rel="home">Rabbi John Rosove&#039;s Blog</a></h1>
									</hgroup>
			</div><!-- end #main-title -->

							<div id="search">
					
<form method="get" action="https://rabbijohnrosove.blog//" >
	<div>
		<label for="s" class="assistive-text">Search:</label>
		<input type="text" value="Search&hellip;" name="s" id="s" onfocus="this.value=''" />
		<input type="submit" name="search" value="Go" />
	</div>
</form>
				</div><!-- end #search -->
			
			<div id="main-image">
							<a href="https://rabbijohnrosove.blog/">
													<img src="https://rabbijohnrosove.files.wordpress.com/2011/07/blog-header1.jpg" width="960" height="260" alt="Rabbi John Rosove&#039;s Blog" title="Rabbi John Rosove&#039;s Blog" />
									</a>
						</div><!-- end #main-image -->
		</header><!-- #branding -->
		<div id="main" class="clear-fix">

	<div id="primary">
		<div id="content" class="clear-fix">

		
			<article id="post-8311" class="post-8311 post type-post status-publish format-standard hentry category-uncategorized">
	<header class="post-title">
				<h1>CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR&nbsp;LIVES”</h1>			<a href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/" class="post-permalink">		<p class="post-date">
			<strong>12</strong>
			<em>Thursday</em>
			<span>Aug 2021</span>
		</p>
	</a>
	<div class="post-info clear-fix">
		<p>
			Posted <span class="by-author"> by <span class="author vcard"><a class="url fn n" href="https://rabbijohnrosove.blog/author/rabbijohnrosove/" title="View all posts by rabbijohnrosove" rel="author">rabbijohnrosove</a></span></span> in <a href="https://rabbijohnrosove.blog/category/uncategorized/" rel="category tag">Uncategorized</a>		</p>
		<p class="post-com-count">
			<strong>&asymp; <a href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/#comments">1 Comment</a></strong>
		</p>
	</div><!-- end .post-info -->
	</header><!-- end .post-title -->

	<div class="post-content clear-fix">
			<div class="post-extras">
					</div><!-- end .post-extras -->

		<div class="post-entry">
			
<div class="wp-block-image"><figure class="aligncenter size-large is-resized"><a href="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg"><img loading="lazy" data-attachment-id="8313" data-permalink="https://rabbijohnrosove.blog/because-my-soul-longs-for-you_front-cover/" data-orig-file="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg" data-orig-size="1827,2774" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="because-my-soul-longs-for-you_front-cover" data-image-description="" data-image-caption="" data-medium-file="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=198" data-large-file="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=529" src="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=674" alt="" class="wp-image-8313" width="674" height="1023" srcset="https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=674 674w, https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=1348 1348w, https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=99 99w, https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=198 198w, https://rabbijohnrosove.files.wordpress.com/2021/08/because-my-soul-longs-for-you_front-cover.jpg?w=768 768w" sizes="(max-width: 674px) 100vw, 674px" /></a></figure></div>



<p class="has-text-align-left">A collection of twenty diverse essays by leading Reform rabbis, educators, and thinkers that highlight their personal encounters with God in everyday life.<br><br><em>Note: <strong>The following is the press release</strong> for a wonderful new volume of personal reflections about the experience of God and the holy. I was one of the contributors and was asked as well to read through the entire volume during the editing process to offer thoughts and suggestions. I was inspired and moved by these articles, and I urge those of you interested in the variety of doors into the holy and the experience of God to purchase this book, especially now in the month of Elul before the High Holidays. </em><br><br>New York, NY – August 2021 – CCAR Press, a division of the Central Conference of American Rabbis, is honored to announce its newest publication, <em>Because My Soul Longs for You: Integrating Theology into Our Lives</em>. The book is co-edited by Rabbi Edwin C. Goldberg of Congregation Beth Shalom in The Woodlands, Texas, and Rabbi Elaine S. Zecher of Temple Israel in Boston. It includes an introduction by Rabbi Joseph A. Skloot, PhD, the Rabbi Aaron D. Panken Assistant Professor of Modern Jewish Intellectual History at Hebrew Union College–Jewish Institute of Religion in New York.<br><br><em>Because My Soul Longs for You</em> responds to one of the most enduring human questions: Where can we find God in our lives? The book’s answer is that holiness can be found in everyday experiences. Contributors discuss how they welcome the Divine presence into their lives in ways that both align with and depart from the traditional ideas of how to encounter God. Among others, the authors explore moments of connection that arise from praying, studying Jewish texts, writing poetry, cooking food, playing music, taking part in acts of service, engaging in physical activity, meditating, and developing interpersonal relationships.</p>



<p><br>“Instead of asking ‘Do you believe in God?’ Rabbis Zecher and Goldberg ask the more fruitful ‘How do you experience God?’” said Rabbi Angela Buchdahl, Senior Rabbi of New York City’s Central Synagogue. “Their book compiles the transformative experiences of twenty souls who share their encounter with the Divine. Through their stories, we access new language for understanding how we might discover God in our lives, and perhaps realize that God has been with us all along.&#8221;</p>



<p><br>The anthology brings together a diverse group of rabbis and teachers. Among them are Rabbi Anne Brenner, LCSW, a professor at the Academy for Jewish Religion in California and a psychotherapist; Rabbi Rebecca L. Dubowe, the world’s first female Deaf rabbi; Ilana Kurshan, a teacher at the Conservative Yeshiva in Jerusalem and the author of the award-winning memoir <em>If All the Seas Were Ink</em>; Rabbi Hara Person, Chief Executive of the Central Conference of American Rabbis; and Rabbi John L. Rosove, Senior Rabbi Emeritus of Temple Israel of Hollywood and national co-chair of JStreet’s Rabbinic and Cantorial Cabinet.<br><br>&#8220;This book is not only phenomenal, it is also phenomenological—it relates to the ways in which God is experienced rather than simply conceptualized,” said Rabbi Dr. Michael Marmur, Associate Professor and former Provost at Hebrew Union College–Jewish Institute of Religion, Jerusalem. “These highly reflective and courageous essays evoke the biblical image of a graceful animal thirsting for water at the brook. So the soul longs for God, experienced in various life situations and described with both beauty and honesty. <em>Because My Soul Longs for You</em> places the soul where it belongs—in the lives and experiences of persons.”</p>



<p><br>“We think of prayer and study as ways to engage with God, but what about cooking, writing, and making art? Where can we find spirituality in the midst of fear, grief, and conflict? This book brings together some of today’s most creative Jewish minds to answer these questions and many more,” said Rafael Chaiken, Director of CCAR Press. “We hope it will encourage readers to find personal practices that strengthen their own connection to God.”</p>



<p><br><em>Because My Soul Longs for You: Integrating Theology into Our Lives </em>is available on CCARPress.org.<br><br>###</p>



<p>About Reform Judaism Publishing and CCAR Press: CCAR Press is the official publisher of the Reform Movement and a division of the Central Conference of American Rabbis. Since 1889, the Central Conference of American Rabbis has been a center for lifelong rabbinic learning, professional development, and publishing for the 2,300 rabbis who serve more than 1.5 million Reform Jews throughout North America, Israel, and the world. CCAR Press publishes liturgical resources and texts on Jewish practice that serve its member rabbis, the Reform Movement, and the Jewish community as a whole. CCAR Press, through its trade imprint Reform Judaism Publishing (RJP), is the steward of the Reform Movement’s sacred texts, including its Torah Commentaries and prayerbooks. In addition to books, CCAR Press publishes CCAR Journal: The Reform Jewish Quarterly, and a wide-range of electronic resources, including e-books, apps, and Visual T&#8217;filah.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8311" class="share-twitter sd-button share-icon" href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8311" class="share-facebook sd-button share-icon" href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-25064604-8311-6115bcc94af18' data-src='//widgets.wp.com/likes/index.html?ver=20210413#blog_id=25064604&amp;post_id=8311&amp;origin=rabbijohnrosove.wordpress.com&amp;obj_id=25064604-8311-6115bcc94af18&amp;domain=rabbijohnrosove.blog' data-name='like-post-frame-25064604-8311-6115bcc94af18' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>					</div><!-- end .post-entry -->
	</div><!-- end .post-content -->

	</article><!-- #post-8311 -->

			<nav id="nav-below" class="clear-fix">
				<h1 class="assistive-text">Post navigation</h1>
				<span class="nav-previous"><a href="https://rabbijohnrosove.blog/2021/07/29/gandhi-said/" rel="prev">&larr; Previous post</a></span>
				<span class="nav-next"></span>
			</nav><!-- #nav-below -->

			<div id="comments">
	
	
			<h3 id="comments-title">
			<span>1</span> thought on &ldquo;CCAR PRESS ANNOUNCES RELEASE OF “BECAUSE MY SOUL LONGS FOR YOU: INTEGRATING THEOLOGY INTO OUR&nbsp;LIVES”&rdquo;		</h3>

		
		<ol class="commentlist">
			
			<li class="comment even thread-even depth-1 highlander-comment" id="comment-11425">

				<div class="comment-heading clear-fix">
					<p class="comment-author">
						<img alt='' src='https://1.gravatar.com/avatar/a881c75deb2add2bf0c0c2db80464692?s=32&#038;d=identicon&#038;r=G' class='avatar avatar-32' height='32' width='32' />						<span>Harriett Bay</span> <em>said:</em>					</p>
					<p class="comment-date">
						<a href="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/#comment-11425"><time pubdate datetime="2021-08-12T16:37:12+00:00">August 12, 2021 at 4:37 PM</time></a>					</p>
				</div>
				<div class="comment-text">
					<p>John: </p>
<p>I have a book for you in case you haven&#8217;t read it- Genius &amp; Anxiety: How Jews Changed the World, 1847-1947 by Norman Lebrecht </p>
<p>xo Harriett </p>
<p>On Thu, Aug 12, 2021 at 8:20 AM Rabbi John Rosove&#8217;s Blog  wrote: </p>
<p>&gt; rabbijohnrosove posted: &#8221; A collection of twenty diverse essays by leading &gt; Reform rabbis, educators, and thinkers that highlight their personal &gt; encounters with God in everyday life.Note: The following is the press &gt; release for a wonderful new volume of personal reflections abo&#8221; &gt;</p>
										<p class="reply-link"><a rel='nofollow' class='comment-reply-link' href='https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/?replytocom=11425#respond' data-commentid="11425" data-postid="8311" data-belowelement="comment-11425" data-respondelement="respond" data-replyto="Reply to Harriett Bay" aria-label='Reply to Harriett Bay'>Reply</a></p>
					<p class="edit-comment"></p>
				</div>
		</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://rabbijohnrosove.blog/wp-comments-post.php" method="post" id="commentform" class="comment-form"><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="99a2d52ead" /><input type="hidden" name="_wp_http_referer" value="/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function () {

	function hide( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.setProperty( 'display', 'none' );
		}
	}

	function show( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.removeProperty( 'display' );
		}
	}

	var input = document.createElement( 'input' );
	var comment = document.querySelector( '#comment' );

	if ( input && comment && 'placeholder' in input ) {
		var label = document.querySelector( '.comment-textarea label' );
		if ( label ) {
			var text = label.textContent;
			label.parentNode.removeChild( label );
			comment.setAttribute( 'placeholder', text );
		}
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	hide( '#comment-form-identity' );
	hide( '#comment-form-subscribe' );
	hide( '#commentform .form-submit' );

	if ( comment ) {
		comment.style.height = '10px';

		var handler = function () {
			comment.style.height = HighlanderComments.initialHeight + 'px';
			show( '#comment-form-identity' );
			show( '#comment-form-subscribe' );
			show( '#commentform .form-submit' );
			HighlanderComments.resizeCallback();

			comment.removeEventListener( 'focus', handler );
		};

		comment.addEventListener( 'focus', handler );
	}
}

if ( document.readyState !== 'loading' ) {
	highlander_expando_javascript();
} else {
	if ( typeof window.jQuery === 'function' ) {
		// Use jQuery's `ready` if available.
		// This solves some scheduling issues between this script and the main highlander script.
		jQuery( document ).ready( highlander_expando_javascript );
	} else {
		// If not available, add a vanilla event listener.
		document.addEventListener( 'DOMContentLoaded', highlander_expando_javascript );
	}
}

</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit wp-block-button"><input name="submit" type="submit" id="comment-submit" class="submit wp-block-button__link" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8311' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2c210249f5" /></p>
<input type="hidden" name="genseq" value="1628814537" />
<input type="hidden" id="ak_js" name="ak_js" value="110"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

		
		</div><!-- end #content -->
	</div><!-- end #primary -->

	
	<div id="secondary" class="widget-area" role="complementary">
		
		<aside id="blog_subscription-5" class="sidebar-widget widget_blog_subscription jetpack_subscription_widget"><h1 class="widget-title"><label for="subscribe-field">Email Subscription</label></h1>
			<form
				action="https://subscribe.wordpress.com"
				method="post"
				accept-charset="utf-8"
				id=""
			>
				<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
					<div class="jetpack-subscribe-count">
						<p>
						Join 336 other followers						</p>
					</div>
									<p id="subscribe-email">
					<label
						id="subscribe-field-label"
						for="subscribe-field"
						class="screen-reader-text"
					>
						Email Address:					</label>

					<input
							type="email"
							name="email"
							
							style="width: 95%; padding: 1px 10px"
							placeholder="Enter your email address"
							value=""
							id="subscribe-field"
						/>				</p>

				<p id="subscribe-submit"
									>
                    <input type="hidden" name="action" value="subscribe"/>
                    <input type="hidden" name="blog_id" value="25064604"/>
                    <input type="hidden" name="source" value="https://rabbijohnrosove.blog/2021/08/12/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives/"/>
                    <input type="hidden" name="sub-type" value="widget"/>
                    <input type="hidden" name="redirect_fragment" value="blog_subscription-5"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="3f597c62e7" />                    <button type="submit"
	                    		                	                >
	                    Sign me up!                    </button>
                </p>
            </form>
			
</aside><aside id="archives-5" class="sidebar-widget widget_archive"><h1 class="widget-title">Archive</h1>
			<ul>
					<li><a href='https://rabbijohnrosove.blog/2021/08/'>August 2021</a>&nbsp;(1)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/07/'>July 2021</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/06/'>June 2021</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/05/'>May 2021</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/04/'>April 2021</a>&nbsp;(4)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/03/'>March 2021</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/02/'>February 2021</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/01/'>January 2021</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/12/'>December 2020</a>&nbsp;(5)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/11/'>November 2020</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/10/'>October 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/09/'>September 2020</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/08/'>August 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/07/'>July 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/06/'>June 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/05/'>May 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/04/'>April 2020</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/03/'>March 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/02/'>February 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/01/'>January 2020</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/12/'>December 2019</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/11/'>November 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/10/'>October 2019</a>&nbsp;(5)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/09/'>September 2019</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/08/'>August 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/07/'>July 2019</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/06/'>June 2019</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/05/'>May 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/04/'>April 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/03/'>March 2019</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/02/'>February 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/01/'>January 2019</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/12/'>December 2018</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/11/'>November 2018</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/10/'>October 2018</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/09/'>September 2018</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/08/'>August 2018</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/07/'>July 2018</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/06/'>June 2018</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/05/'>May 2018</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/04/'>April 2018</a>&nbsp;(18)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/03/'>March 2018</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/02/'>February 2018</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/01/'>January 2018</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/12/'>December 2017</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/11/'>November 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/10/'>October 2017</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/09/'>September 2017</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/08/'>August 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/07/'>July 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/06/'>June 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/05/'>May 2017</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/04/'>April 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/03/'>March 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/02/'>February 2017</a>&nbsp;(14)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/01/'>January 2017</a>&nbsp;(22)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/12/'>December 2016</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/11/'>November 2016</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/10/'>October 2016</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/09/'>September 2016</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/08/'>August 2016</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/07/'>July 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/06/'>June 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/05/'>May 2016</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/04/'>April 2016</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/03/'>March 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/02/'>February 2016</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/01/'>January 2016</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/12/'>December 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/11/'>November 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/10/'>October 2015</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/09/'>September 2015</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/08/'>August 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/07/'>July 2015</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/06/'>June 2015</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/05/'>May 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/04/'>April 2015</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/03/'>March 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/02/'>February 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/01/'>January 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/12/'>December 2014</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/11/'>November 2014</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/10/'>October 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/09/'>September 2014</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/08/'>August 2014</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/07/'>July 2014</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/06/'>June 2014</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/05/'>May 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/04/'>April 2014</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/03/'>March 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/02/'>February 2014</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/01/'>January 2014</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/12/'>December 2013</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/11/'>November 2013</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/10/'>October 2013</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/09/'>September 2013</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/08/'>August 2013</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/07/'>July 2013</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/06/'>June 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/05/'>May 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/04/'>April 2013</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/03/'>March 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/02/'>February 2013</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/01/'>January 2013</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/12/'>December 2012</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/11/'>November 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/10/'>October 2012</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/09/'>September 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/08/'>August 2012</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/07/'>July 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/06/'>June 2012</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/05/'>May 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/04/'>April 2012</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/03/'>March 2012</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/02/'>February 2012</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/01/'>January 2012</a>&nbsp;(14)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/12/'>December 2011</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/11/'>November 2011</a>&nbsp;(23)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/10/'>October 2011</a>&nbsp;(21)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/09/'>September 2011</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/08/'>August 2011</a>&nbsp;(31)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/07/'>July 2011</a>&nbsp;(8)</li>
			</ul>

			</aside><aside id="categories-3" class="sidebar-widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-3051662"><a href="https://rabbijohnrosove.blog/category/american-jewish-life/">American Jewish Life</a> (458)
</li>
	<li class="cat-item cat-item-61823469"><a href="https://rabbijohnrosove.blog/category/american-politics-and-life/">American Politics and Life</a> (417)
</li>
	<li class="cat-item cat-item-177"><a href="https://rabbijohnrosove.blog/category/art/">Art</a> (30)
</li>
	<li class="cat-item cat-item-1037807"><a href="https://rabbijohnrosove.blog/category/beauty-in-nature/">Beauty in Nature</a> (24)
</li>
	<li class="cat-item cat-item-97301"><a href="https://rabbijohnrosove.blog/category/book-recommendations/">Book Recommendations</a> (52)
</li>
	<li class="cat-item cat-item-354469"><a href="https://rabbijohnrosove.blog/category/divrei-torah/">Divrei Torah</a> (159)
</li>
	<li class="cat-item cat-item-8289"><a href="https://rabbijohnrosove.blog/category/ethics/">Ethics</a> (490)
</li>
	<li class="cat-item cat-item-1314"><a href="https://rabbijohnrosove.blog/category/film-reviews/">Film Reviews</a> (6)
</li>
	<li class="cat-item cat-item-442405"><a href="https://rabbijohnrosove.blog/category/health-and-well-being/">Health and Well-Being</a> (156)
</li>
	<li class="cat-item cat-item-4325"><a href="https://rabbijohnrosove.blog/category/holidays/">Holidays</a> (136)
</li>
	<li class="cat-item cat-item-2720"><a href="https://rabbijohnrosove.blog/category/human-rights/">Human rights</a> (57)
</li>
	<li class="cat-item cat-item-65178885"><a href="https://rabbijohnrosove.blog/category/inuyim-prayer-reflections-and-ruminations/">Inuyim &#8211; Prayer reflections and ruminations</a> (95)
</li>
	<li class="cat-item cat-item-698292"><a href="https://rabbijohnrosove.blog/category/israel-and-palestine/">Israel and Palestine</a> (358)
</li>
	<li class="cat-item cat-item-741786"><a href="https://rabbijohnrosove.blog/category/israelzionism/">Israel/Zionism</a> (502)
</li>
	<li class="cat-item cat-item-168299"><a href="https://rabbijohnrosove.blog/category/jewish-history/">Jewish History</a> (441)
</li>
	<li class="cat-item cat-item-379108"><a href="https://rabbijohnrosove.blog/category/jewish-identity/">Jewish Identity</a> (372)
</li>
	<li class="cat-item cat-item-7847001"><a href="https://rabbijohnrosove.blog/category/jewish-christian-relations/">Jewish-Christian Relations</a> (51)
</li>
	<li class="cat-item cat-item-264916685"><a href="https://rabbijohnrosove.blog/category/jewish-islamic-relations/">Jewish-Islamic Relations</a> (57)
</li>
	<li class="cat-item cat-item-94780"><a href="https://rabbijohnrosove.blog/category/life-cycle/">Life Cycle</a> (53)
</li>
	<li class="cat-item cat-item-61125721"><a href="https://rabbijohnrosove.blog/category/musings-about-godfaithreligious-life/">Musings about God/Faith/Religious life</a> (190)
</li>
	<li class="cat-item cat-item-422"><a href="https://rabbijohnrosove.blog/category/poetry/">Poetry</a> (86)
</li>
	<li class="cat-item cat-item-18129"><a href="https://rabbijohnrosove.blog/category/quote-of-the-day/">Quote of the Day</a> (101)
</li>
	<li class="cat-item cat-item-2282"><a href="https://rabbijohnrosove.blog/category/social-justice/">Social Justice</a> (355)
</li>
	<li class="cat-item cat-item-955"><a href="https://rabbijohnrosove.blog/category/stories/">Stories</a> (74)
</li>
	<li class="cat-item cat-item-9305"><a href="https://rabbijohnrosove.blog/category/tributes/">Tributes</a> (30)
</li>
	<li class="cat-item cat-item-1"><a href="https://rabbijohnrosove.blog/category/uncategorized/">Uncategorized</a> (482)
</li>
	<li class="cat-item cat-item-98215"><a href="https://rabbijohnrosove.blog/category/womens-rights/">Women&#039;s Rights</a> (152)
</li>
			</ul>

			</aside><aside id="linkcat-1356" class="sidebar-widget widget_links"><h1 class="widget-title">Blogroll</h1>
	<ul class='xoxo blogroll'>
<li><a href="http://www.peacenow.org">Americans for Peace Now</a></li>
<li><a href="http://www.arza.org">Association of Reform Zionists of America (ARZA)</a></li>
<li><a href="http://www.d-noam.org/">Congregation Darchei Noam</a></li>
<li><a href="http://www.haaretz.com">Haaretz</a></li>
<li><a href="http://www.jstreet.org">J Street</a></li>
<li><a href="http://www.jpost.com">Jerusalem Post</a></li>
<li><a href="http://www.jpost.com/JerusalemReport/Home.aspx">Jerusalem Report</a></li>
<li><a href="http://www.kbyonline.org/mevasseret_zion/index.html">Kehillat Mevesseret Zion</a></li>
<li><a href="http://www.tioh.org">Temple Israel of Hollywood</a></li>
<li><a href="http://www.irac.org">The IRAC</a></li>
<li><a href="http://www.forward.com">The Jewish Daily Forward</a></li>
<li><a href="http://www.jewishjournal.com">The LA Jewish Journal</a></li>
<li><a href="http://www.rac.org">The RAC</a></li>
<li><a href="http://www.urj.org">URJ</a></li>
<li><a href="http://www.wupj.org/">World Union for Progressive Judaism</a></li>

	</ul>
</aside>

	</div><!-- #secondary .widget-area -->


		</div><!-- end #main -->
	</div><!-- end #page-inner -->

	<footer id="colophon" role="contentinfo">
		<div id="footer">
			<div id="footer-inner">
				<div id="footer-inner-inner">
					

				</div><!-- end #footer-inner-inner -->
			</div><!-- end #footer-inner -->
		</div>
		<div id="copyright">
			<div id="copyright-inner">
					<div id="copyright-inner-inner">
					<p>
						<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
							</p>
				</div><!-- end #copyright-inner-inner -->
			</div><!-- end #copyright-inner -->
		</div><!-- end #copyright -->
	</footer><!-- end #footer -->

	<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202132y' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-a881c75deb2add2bf0c0c2db80464692">
	</div>
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/rabbijohnrosove.wordpress.com\/public.api\/connect\/?action=request&domain=rabbijohnrosove.blog","logoutURL":"https:\/\/rabbijohnrosove.wordpress.com\/wp-login.php?action=logout&_wpnonce=08913d9c4e","homeURL":"https:\/\/rabbijohnrosove.blog\/","postID":"8311","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1626677336j'></script>

<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20201002";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20210707";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
													<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
								<span class="jp-carousel-icon">
									<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
										<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
											<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
										</mask>
										<g mask="url(#maskInfo)">
											<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
										</g>
									</svg>
								</span>
							</a>
																		<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/rabbijohnrosove.blog\/2021\/08\/12\/ccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives\/":8311};
	</script>
				<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/_static/??-eJyFyz0KgDAMQOELGeMPiot4llqDqLUNTUqvLw4uDjq+Bx9mBhu8klc8E7BL6+YFrYkhCTmUvDFFmJNfHJVWpMAfsZOysQc84wtFckZpAQ6ir7rZdI513wx929RdtV/vrT+f?cssminify=yes' type='text/css' media='all' />
<script id='coblocks-lightbox-js-extra'>
var coblocksLigthboxData = {"closeLabel":"Close Gallery","leftLabel":"Previous","rightLabel":"Next"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"\/wp-content\/mu-plugins\/carousel\/swiper-bundle.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/rabbijohnrosove.blog\/wp-admin\/admin-ajax.php","nonce":"169d238e94","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/rabbijohnrosove.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Frabbijohnrosove.blog%2F2021%2F08%2F12%2Fccar-press-announces-release-of-because-my-soul-longs-for-you-integrating-theology-into-our-lives%2F","blog_id":"25064604","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"stats_query_args":"blog=25064604&v=wpcom&tz=0&user_id=0&subd=rabbijohnrosove","is_public":"1"};
</script>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s2.wp.com/_static/??-eJyNUO1OwzAMfCESt0Pq4AfiUVCaeK3bfBEnK+PpFyaKRIU6fjln313OhiUKHXxGn2FiMHgmjfFDTvwAv0fTe8F0+S6S/JlwuUubMEelZ5GQ6RO3dFdEtGUgz2BpRoYqKjgqbyymLXll6tDboGeGg2wb2YIhvn289oWlYcx9+NmBvLbFVPcbyblqVvNEe5GO/E4kZepc9CqBU5wx1ZfIqW7DfzlXiK5Hc8dUqxQKo4X1MmtjR5PQqoxGxMB5g/biz8QOs3iUDbzVpHAKyf0jmVhivdIG7ui+coiTVZSAR5XID2utolf30naHp/a5OzbddAXftedA'></script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20210413#ver=20210413&amp;origin=https://rabbijohnrosove.blog' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>
	
		<script src="//stats.wp.com/w.js?61" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'25064604','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'25064604','v':'wpcom','tz':'0','user_id':'0','post':'8311','subd':'rabbijohnrosove'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE0/bU8yQkx3RTR3RmZTSndoTltKYUswVVM5eGtbRVYtRGJ+W04seEdtUHB+bnx5YkI2XXZwVFgwdD80VDItXUVtSFRwWiYwLEJNNURRZE4xRndOdmUuYix8eX45Skx1W2QrWkNmUGtFdFZhcC9kZTF4PUZ+WURjU28sZy83WF9xcU5FclFUb3FbOEIyaV05eEdhJU5HN3M2UHpLdXVdbFM2NTVENTBCLGdicnBnZWdGKz12TEwsVXhhLz9icEtufFVPUVBCbU54Ryw1LFFYK0NKbjd8fDhObW5OV3NzdXM/U2Q0V3RDUUY3KzErUm8lc1UlUkc1dzUlfCtjaW1MbCtRaV1kZDBrK0E1JVlZZ0NlY2Nbb2FRbEElP0t1Z1h2NEYxWg=='}]);
_stq.push([ 'clickTrackerInit', '25064604', '8311' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></div><!-- end #page -->
</body>
</html>
