<!DOCTYPE html>
<!--[if IE 7]>
<html id="ie7" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>My Favorite Podcasts | Rabbi John Rosove&#039;s Blog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://rabbijohnrosove.blog/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://s2.wp.com/wp-content/themes/pub/chateau/js/html5.js" type="text/javascript"></script>
<![endif]-->
<meta name='robots' content='max-image-preview:large' />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//rabbijohnrosove.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; Feed" href="https://rabbijohnrosove.blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; Comments Feed" href="https://rabbijohnrosove.blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rabbi John Rosove&#039;s Blog &raquo; My Favorite Podcasts Comments Feed" href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1652185836h&ver=6.0.1-alpha-53658"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNkt1uAiEQhV+oA1m11l40fRZ+JhQdWMKAhrcvbluzXa2WC5ID8x0ODPKUwIyxYCwyVEhUnY8sT8mMATh4wrZQwjA/ydtYRlIFLaSRy0Ldw8gfkOUeS1LmAJO6Kv+pdbVLjdn1nYzyOKzFi1hLXT1ZqWmcDHRWuUkujfBi5KOhas/nsAxovULCMAWZiUSqYQZCp0wTwcfHeN+b61/Q3+GnpLM7qzbWAi57u4j9b4usio+OH+Bm/MZWYtiJAdiHRAgZj2IlredyqYDbRrO2nRvQ10NS169wB/v6TVqnjMzQ5+BrgPLRwant7+Ft2D7vXjd9bPefSgP8fg==?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<style id='global-styles-inline-css'>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</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJx9i9EKwjAMAH/IGDdF9EH8li7ErtImZUkZ+3snvijC3u7gDucKpOIsjj5yYcPaBqQxOIeG5kvmPZntcDtMQp8Y5kpa/pbSoOYWkxhGVshKwZPKj8AjhzRtrRMPWeOKEdfqS9/Tvdy60/Xcd/3xcHm+ANXhUEc=?cssminify=yes' type='text/css' media='all' />
<link crossorigin='anonymous' rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-6-1' href='https://s2.wp.com/_static/??-eJxti8sKgCAQAH8oW6KXHaJvMTE1Vldapd+PDh2iTsPADJxJaIrZxAyhiITF+siQiLPYUPkD2KnDR/uw1swV/F9M2isUSJbe8pmyM8EwuA4s0qrwDpYwN0PfymmUstsvZXo34g==?cssminify=yes' type='text/css' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='media-video-jwt-bridge-js-extra'>
var videopressAjax = {"ajaxUrl":"https:\/\/rabbijohnrosove.wordpress.com\/wp-admin\/admin-ajax.php","bridgeUrl":"https:\/\/s2.wp.com\/wp-content\/mu-plugins\/videopress\/js\/videopress-token-bridge.js","post_id":"8722"};
</script>
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"25064604","siteURL":"https:\/\/rabbijohnrosove.blog","xhrURL":"https:\/\/rabbijohnrosove.blog\/wp-admin\/admin-ajax.php","nonce":"252f234e91","isLoggedIn":"","statusMessage":"","subsEmailDefault":"instantly","proxyScriptUrl":"https:\/\/s0.wp.com\/wp-content\/js\/wpcom-proxy-request.js?ver=20211021","shortlink":"https:\/\/wp.me\/p1HarO-2gG","i18n":{"followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jEsOwjAMBS+EiYpEKQvEWVpiooQktmyHz+0JK1AXLOfpzbgHw4WqYTWX1BVaYkZoijKHvkGsV9om3bifX2nAuYVY1Qnm2dADk9qK1lavSzZgoefrT/EePRILqn6ML4HRDSssEn3A7p/LaRj3u8NxmKYxvQFnG0na'></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-2' href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1650315457h&cssminify=yes' type='text/css' media='all' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rabbijohnrosove.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/" />
<link rel='shortlink' href='https://wp.me/p1HarO-2gG' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Frabbijohnrosove.blog%2F2022%2F07%2F31%2Fmy-favorite-podcasts%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Frabbijohnrosove.blog%2F2022%2F07%2F31%2Fmy-favorite-podcasts%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="My Favorite Podcasts" />
<meta property="og:url" content="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/" />
<meta property="og:description" content="There are currently nearly 2.2 million podcasts out there, according to ListenNotes. According to Amplifi and Podnews, 44% of the podcasts have less than 3 episodes. Only 720,000 podcasts have more…" />
<meta property="article:published_time" content="2022-07-31T12:20:29+00:00" />
<meta property="article:modified_time" content="2022-07-31T12:44:39+00:00" />
<meta property="og:site_name" content="Rabbi John Rosove&#039;s Blog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta name="twitter:text:title" content="My Favorite Podcasts" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://rabbijohnrosove.blog/?openidserver=1' />
<link rel='openid.delegate' href='https://rabbijohnrosove.blog/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://rabbijohnrosove.blog/osd.xml" title="Rabbi John Rosove&#039;s Blog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 0, tn: 'chateau', amp: false, siteid: 8982, blogid: 25064604, consent: __ATA_CC(), uloggedin: 0, flag: 2 };
		</script>
		<script type="text/javascript">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</script><meta name="application-name" content="Rabbi John Rosove&#039;s Blog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://rabbijohnrosove.blog/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="There are currently nearly 2.2 million podcasts out there, according to ListenNotes. According to Amplifi and Podnews, 44% of the podcasts have less than 3 episodes. Only 720,000 podcasts have more than 10 episodes. Of those 720,000 podcasts, only 156,000 are releasing a weekly episode. There are more than 1 billion podcast listeners every week&hellip;" />
</head>

<body class="post-template-default single single-post postid-8722 single-format-standard customizer-styles-applied two-column content-sidebar highlander-enabled highlander-light">
<div id="page" class="hfeed">
		<div id="page-inner">
		<header id="branding" role="banner">
			<nav id="menu" role="navigation">
				<ul class="menu clear-fix">
<li class="page_item page-item-2"><a href="https://rabbijohnrosove.blog/about/">About</a></li>
</ul>
			</nav><!-- end #menu -->

			<div id="main-title">
				<hgroup>
					<h1 id="site-title"><a href="https://rabbijohnrosove.blog/" title="Rabbi John Rosove&#039;s Blog" rel="home">Rabbi John Rosove&#039;s Blog</a></h1>
									</hgroup>
			</div><!-- end #main-title -->

							<div id="search">
					
<form method="get" action="https://rabbijohnrosove.blog//" >
	<div>
		<label for="s" class="assistive-text">Search:</label>
		<input type="text" value="Search&hellip;" name="s" id="s" onfocus="this.value=''" />
		<input type="submit" name="search" value="Go" />
	</div>
</form>
				</div><!-- end #search -->
			
			<div id="main-image">
							<a href="https://rabbijohnrosove.blog/">
													<img src="https://rabbijohnrosove.files.wordpress.com/2011/07/blog-header1.jpg" width="960" height="260" alt="Rabbi John Rosove&#039;s Blog" title="Rabbi John Rosove&#039;s Blog" />
									</a>
						</div><!-- end #main-image -->
		</header><!-- #branding -->
		<div id="main" class="clear-fix">

	<div id="primary">
		<div id="content" class="clear-fix">

		
			<article id="post-8722" class="post-8722 post type-post status-publish format-standard hentry category-uncategorized">
	<header class="post-title">
				<h1>My Favorite Podcasts</h1>			<a href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/" class="post-permalink">		<p class="post-date">
			<strong>31</strong>
			<em>Sunday</em>
			<span>Jul 2022</span>
		</p>
	</a>
	<div class="post-info clear-fix">
		<p>
			Posted <span class="by-author"> by <span class="author vcard"><a class="url fn n" href="https://rabbijohnrosove.blog/author/rabbijohnrosove/" title="View all posts by rabbijohnrosove" rel="author">rabbijohnrosove</a></span></span> in <a href="https://rabbijohnrosove.blog/category/uncategorized/" rel="category tag">Uncategorized</a>		</p>
		<p class="post-com-count">
			<strong>&asymp; <a href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/#comments">1 Comment</a></strong>
		</p>
	</div><!-- end .post-info -->
	</header><!-- end .post-title -->

	<div class="post-content clear-fix">
			<div class="post-extras">
					</div><!-- end .post-extras -->

		<div class="post-entry">
			
<p>There are currently nearly 2.2 million podcasts out there, according to <a href="https://listennotes.com/stats/">ListenNotes</a>. According to <a rel="noreferrer noopener" href="https://www.amplifimedia.com/blogstein/m7ei93yk38uivdv5llgbfkv7li87xw" target="_blank">Amplifi and Podnews</a>, 44% of the podcasts have less than 3 episodes. Only 720,000 podcasts have more than 10 episodes. Of those 720,000 podcasts, only 156,000 are releasing a weekly episode.</p>



<p>There are more than 1 billion podcast listeners <em>every week (really!).</em> Most listeners are in Asia, India, and China and are responsible for 45% of all podcast listener-ship in the world. In the United States, 80 million people, or 28% of the population (over the age of 12) are weekly listeners.</p>



<p>Most of the podcasts are coming from the United States (1.4 million to be precise). While India and China have the most listeners, they only account for 42,000 podcasts. 1.3 million Podcasts are in English. The second most popular language, Spanish, is far behind with only 220,000 podcasts.</p>



<p>[Source for all the above stats: <a href="https://podcastpage.io/podcast-statistics/">https://podcastpage.io/podcast-statistics/</a>]</p>



<p>So, 80 million of us Americans are devotees of podcasts. I listen every morning on my 60-90 minutes-walk in my neighborhood, whenever I’m driving alone on a long distance journey in my car (in LA, that is a fairly frequent occurrence), and occasionally when I’m doing the laundry, washing dishes, or doing other household tasks that bore me silly. I’m sure, given the numbers above, I’m not the only one. </p>



<p>My preferred Podcasts are those in which I can learn something new about our times in politics, current affairs, thought, and history in the United States, Israel, the Jewish world, and beyond. I listen to Podcasts that express ideas from the political left, right, and center of the political spectrum. I do not listen to Podcasts whose hosts rile me up emotionally – life is just too short. I look to be both stimulated and entertained.</p>



<p>Here is my preferred current list:</p>



<p></p>



<p><strong>American News, Politics, and Commentary </strong></p>



<p><em>Post Reports</em> – Daily from <em>The Washington Post</em> with Martine Powers.</p>



<p><em>The Daily</em> – Daily from <em>The New York Times</em> with Michael Barbaro and Sabrina Tavernise.</p>



<p><em>Hell and High Wa</em>ter – Twice-weekly with John Heilemann.</p>



<p><em>Pod Save America</em> – Twice-weekly with Jon Favreau, Jon Lovett, Dan Pfeiffer, and Tommy Vietor.</p>



<p><em>The Bulwark</em> – Twice-weekly with Charlie Sykes.</p>



<p><em>The Ezra Klein Show</em> &#8211; Twice-weekly.</p>



<p><em>Sway</em> &#8211; Twice-weekly with Kara Swisher from the <em>New York Times</em>.</p>



<p><em>The Lincoln Project</em> – Twice-weekly founded by former and incumbent anti-Trump Republicans.</p>



<p><em>Politics War Roo</em>m – Weekly with James Carville and Al Hunt.</p>



<p><em>The New Yorker</em>: <em>Politics and More</em> – Weekly with different hosts.</p>



<p><em>Hacks on Tap</em> – Weekly with David Axelrod, Mike Murphy, and Robert Gibbs.</p>



<p><em>The Axe Files</em> – Weekly with David Axelrod.</p>



<p></p>



<p><strong>History</strong></p>



<p><em>HistoryExtra </em>– Daily from the <em>BBC History Magazine.</em></p>



<p><em>Reflections of History</em> – Daily with Jon Meacham (5 minutes each episode).</p>



<p><em>History this Week</em> – Weekly with Sally Helm.</p>



<p></p>



<p><strong>Jewish and Israeli News and Commentary</strong></p>



<p><em>The Daily Briefing</em> – From <em>The Times of Israel</em> with Jessica Steinberg and Amanda Bush Eldan.</p>



<p><em>The Promised</em> – Weekly from Tel Aviv (TLV1) with Noah Ephron, Allison Kaplan Sommer, and Don Futterman.</p>



<p><em>Tel Aviv Review</em> – Weekly from the Jerusalem Leer Institute on TLV1 with Gideon Halpern.</p>



<p><em>Haaretz Weekly</em> – With Allison Kaplan Sommer.</p>



<p><em>For Heaven’s Sake</em> – Every other week from the Shalom Hartman Institute with Rabbi Donniel Hartman, Yossi Klein Halevi, and Elana Stein-Hain.</p>



<p><em>In These Times</em> – Every other week with Rabbi Ammiel Hirsch, Stephen S. Wise Free Synagogue, NY.</p>



<p>No – I don’t listen to every podcast every week. </p>



<p>When I become weary of the news and commentary, I shift to music (usually classical), or I take off my head-phones, listen to the birds in the early morning hours in Sherman Oaks and Studio City as the sun rises, and let my mind wander. </p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8722" class="share-twitter sd-button share-icon" href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8722" class="share-facebook sd-button share-icon" href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-25064604-8722-62e8667ef0316' data-src='//widgets.wp.com/likes/index.html?ver=20220105#blog_id=25064604&amp;post_id=8722&amp;origin=rabbijohnrosove.wordpress.com&amp;obj_id=25064604-8722-62e8667ef0316&amp;domain=rabbijohnrosove.blog' data-name='like-post-frame-25064604-8722-62e8667ef0316' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>					</div><!-- end .post-entry -->
	</div><!-- end .post-content -->

	</article><!-- #post-8722 -->

			<nav id="nav-below" class="clear-fix">
				<h1 class="assistive-text">Post navigation</h1>
				<span class="nav-previous"><a href="https://rabbijohnrosove.blog/2022/07/28/two-strong-recommendations-of-new-israeli-films-streaming-on-netflix/" rel="prev">&larr; Previous post</a></span>
				<span class="nav-next"></span>
			</nav><!-- #nav-below -->

			<div id="comments">
	
	
			<h3 id="comments-title">
			<span>1</span> thought on &ldquo;My Favorite Podcasts&rdquo;		</h3>

		
		<ol class="commentlist">
			
			<li class="comment byuser comment-author-jaymillerblueconnectorg even thread-even depth-1 highlander-comment" id="comment-13488">

				<div class="comment-heading clear-fix">
					<p class="comment-author">
						<img alt='' src='https://1.gravatar.com/avatar/d6d23bf2d0e53f17f18290a2646cdd94?s=32&#038;d=identicon&#038;r=G' class='avatar avatar-32' height='32' width='32' />						<span>Rabbi Jay Miller</span> <em>said:</em>					</p>
					<p class="comment-date">
						<a href="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/#comment-13488"><time pubdate datetime="2022-07-31T17:51:31+00:00">July 31, 2022 at 5:51 PM</time></a>					</p>
				</div>
				<div class="comment-text">
					<p>Hi John.</p>
<p>Appreciated and also a nice window to the nature of our lives &#8211; civic and personal.</p>
<p>Take Care,</p>
<p>Jay ________________________________</p>
										<p class="reply-link"><a rel='nofollow' class='comment-reply-link' href='https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/?replytocom=13488#respond' data-commentid="13488" data-postid="8722" data-belowelement="comment-13488" data-respondelement="respond" data-replyto="Reply to Rabbi Jay Miller" aria-label='Reply to Rabbi Jay Miller'>Reply</a></p>
					<p class="edit-comment"></p>
				</div>
		</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/07/31/my-favorite-podcasts/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://rabbijohnrosove.blog/wp-comments-post.php" method="post" id="commentform" class="comment-form"><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="50710c432e" /><input type="hidden" name="_wp_http_referer" value="/2022/07/31/my-favorite-podcasts/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
				 title="Login via Guest" 				>
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
				 title="Login via WordPress.com" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
				 title="Login via Twitter" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
				 title="Login via Facebook" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function () {

	function hide( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.setProperty( 'display', 'none' );
		}
	}

	function show( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.removeProperty( 'display' );
		}
	}

	var input = document.createElement( 'input' );
	var comment = document.querySelector( '#comment' );

	if ( input && comment && 'placeholder' in input ) {
		var label = document.querySelector( '.comment-textarea label' );
		if ( label ) {
			var text = label.textContent;
			label.parentNode.removeChild( label );
			comment.setAttribute( 'placeholder', text );
		}
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	hide( '#comment-form-identity' );
	hide( '#comment-form-subscribe' );
	hide( '#commentform .form-submit' );

	if ( comment ) {
		comment.style.height = '10px';

		var handler = function () {
			comment.style.height = HighlanderComments.initialHeight + 'px';
			show( '#comment-form-identity' );
			show( '#comment-form-subscribe' );
			show( '#commentform .form-submit' );
			HighlanderComments.resizeCallback();

			comment.removeEventListener( 'focus', handler );
		};

		comment.addEventListener( 'focus', handler );
	}
}

if ( document.readyState !== 'loading' ) {
	highlander_expando_javascript();
} else {
	document.addEventListener( 'DOMContentLoaded', highlander_expando_javascript );
}

</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8722' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0547c1fe9b" /></p>
<input type="hidden" name="genseq" value="1659397759" />
<p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="187"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

		
		</div><!-- end #content -->
	</div><!-- end #primary -->

	
	<div id="secondary" class="widget-area" role="complementary">
		
		<aside id="blog_subscription-5" class="sidebar-widget widget_blog_subscription jetpack_subscription_widget"><h1 class="widget-title"><label for="subscribe-field">Email Subscription</label></h1>

			<div class="wp-block-jetpack-subscriptions__container">
			<form
				action="https://subscribe.wordpress.com"
				method="post"
				accept-charset="utf-8"
				id="subscribe-blog"
			>
				<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
				<p id="subscribe-email">
					<label
						id="subscribe-field-label"
						for="subscribe-field"
						class="screen-reader-text"
					>
						Email Address:					</label>

					<input
							type="email"
							name="email"
							
							style="width: 95%; padding: 1px 10px"
							placeholder="Enter your email address"
							value=""
							id="subscribe-field"
						/>				</p>

				<p id="subscribe-submit"
									>
					<input type="hidden" name="action" value="subscribe"/>
					<input type="hidden" name="blog_id" value="25064604"/>
					<input type="hidden" name="source" value="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/"/>
					<input type="hidden" name="sub-type" value="widget"/>
					<input type="hidden" name="redirect_fragment" value="subscribe-blog"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="32a3a112a1" />					<button type="submit"
													class="wp-block-button__link"
																	>
						Sign me up!					</button>
				</p>
			</form>
							<div class="wp-block-jetpack-subscriptions__subscount">
					Join 346 other followers				</div>
						</div>
			
</aside><aside id="archives-5" class="sidebar-widget widget_archive"><h1 class="widget-title">Archive</h1>
			<ul>
					<li><a href='https://rabbijohnrosove.blog/2022/07/'>July 2022</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/06/'>June 2022</a>&nbsp;(5)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/05/'>May 2022</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/04/'>April 2022</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/03/'>March 2022</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/02/'>February 2022</a>&nbsp;(3)</li>
	<li><a href='https://rabbijohnrosove.blog/2022/01/'>January 2022</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/12/'>December 2021</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/11/'>November 2021</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/10/'>October 2021</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/09/'>September 2021</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/08/'>August 2021</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/07/'>July 2021</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/06/'>June 2021</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/05/'>May 2021</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/04/'>April 2021</a>&nbsp;(4)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/03/'>March 2021</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/02/'>February 2021</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2021/01/'>January 2021</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/12/'>December 2020</a>&nbsp;(5)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/11/'>November 2020</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/10/'>October 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/09/'>September 2020</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/08/'>August 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/07/'>July 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/06/'>June 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/05/'>May 2020</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/04/'>April 2020</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/03/'>March 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/02/'>February 2020</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2020/01/'>January 2020</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/12/'>December 2019</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/11/'>November 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/10/'>October 2019</a>&nbsp;(5)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/09/'>September 2019</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/08/'>August 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/07/'>July 2019</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/06/'>June 2019</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/05/'>May 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/04/'>April 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/03/'>March 2019</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/02/'>February 2019</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2019/01/'>January 2019</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/12/'>December 2018</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/11/'>November 2018</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/10/'>October 2018</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/09/'>September 2018</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/08/'>August 2018</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/07/'>July 2018</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/06/'>June 2018</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/05/'>May 2018</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/04/'>April 2018</a>&nbsp;(18)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/03/'>March 2018</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/02/'>February 2018</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2018/01/'>January 2018</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/12/'>December 2017</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/11/'>November 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/10/'>October 2017</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/09/'>September 2017</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/08/'>August 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/07/'>July 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/06/'>June 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/05/'>May 2017</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/04/'>April 2017</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/03/'>March 2017</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/02/'>February 2017</a>&nbsp;(14)</li>
	<li><a href='https://rabbijohnrosove.blog/2017/01/'>January 2017</a>&nbsp;(22)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/12/'>December 2016</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/11/'>November 2016</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/10/'>October 2016</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/09/'>September 2016</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/08/'>August 2016</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/07/'>July 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/06/'>June 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/05/'>May 2016</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/04/'>April 2016</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/03/'>March 2016</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/02/'>February 2016</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2016/01/'>January 2016</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/12/'>December 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/11/'>November 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/10/'>October 2015</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/09/'>September 2015</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/08/'>August 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/07/'>July 2015</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/06/'>June 2015</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/05/'>May 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/04/'>April 2015</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/03/'>March 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/02/'>February 2015</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2015/01/'>January 2015</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/12/'>December 2014</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/11/'>November 2014</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/10/'>October 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/09/'>September 2014</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/08/'>August 2014</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/07/'>July 2014</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/06/'>June 2014</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/05/'>May 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/04/'>April 2014</a>&nbsp;(17)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/03/'>March 2014</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/02/'>February 2014</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2014/01/'>January 2014</a>&nbsp;(15)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/12/'>December 2013</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/11/'>November 2013</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/10/'>October 2013</a>&nbsp;(7)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/09/'>September 2013</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/08/'>August 2013</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/07/'>July 2013</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/06/'>June 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/05/'>May 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/04/'>April 2013</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/03/'>March 2013</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/02/'>February 2013</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2013/01/'>January 2013</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/12/'>December 2012</a>&nbsp;(12)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/11/'>November 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/10/'>October 2012</a>&nbsp;(6)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/09/'>September 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/08/'>August 2012</a>&nbsp;(8)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/07/'>July 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/06/'>June 2012</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/05/'>May 2012</a>&nbsp;(11)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/04/'>April 2012</a>&nbsp;(13)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/03/'>March 2012</a>&nbsp;(10)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/02/'>February 2012</a>&nbsp;(9)</li>
	<li><a href='https://rabbijohnrosove.blog/2012/01/'>January 2012</a>&nbsp;(14)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/12/'>December 2011</a>&nbsp;(16)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/11/'>November 2011</a>&nbsp;(23)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/10/'>October 2011</a>&nbsp;(21)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/09/'>September 2011</a>&nbsp;(19)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/08/'>August 2011</a>&nbsp;(31)</li>
	<li><a href='https://rabbijohnrosove.blog/2011/07/'>July 2011</a>&nbsp;(8)</li>
			</ul>

			</aside><aside id="categories-3" class="sidebar-widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-3051662"><a href="https://rabbijohnrosove.blog/category/american-jewish-life/">American Jewish Life</a> (458)
</li>
	<li class="cat-item cat-item-61823469"><a href="https://rabbijohnrosove.blog/category/american-politics-and-life/">American Politics and Life</a> (417)
</li>
	<li class="cat-item cat-item-177"><a href="https://rabbijohnrosove.blog/category/art/">Art</a> (30)
</li>
	<li class="cat-item cat-item-1037807"><a href="https://rabbijohnrosove.blog/category/beauty-in-nature/">Beauty in Nature</a> (24)
</li>
	<li class="cat-item cat-item-97301"><a href="https://rabbijohnrosove.blog/category/book-recommendations/">Book Recommendations</a> (52)
</li>
	<li class="cat-item cat-item-354469"><a href="https://rabbijohnrosove.blog/category/divrei-torah/">Divrei Torah</a> (159)
</li>
	<li class="cat-item cat-item-8289"><a href="https://rabbijohnrosove.blog/category/ethics/">Ethics</a> (490)
</li>
	<li class="cat-item cat-item-1314"><a href="https://rabbijohnrosove.blog/category/film-reviews/">Film Reviews</a> (6)
</li>
	<li class="cat-item cat-item-442405"><a href="https://rabbijohnrosove.blog/category/health-and-well-being/">Health and Well-Being</a> (156)
</li>
	<li class="cat-item cat-item-4325"><a href="https://rabbijohnrosove.blog/category/holidays/">Holidays</a> (136)
</li>
	<li class="cat-item cat-item-2720"><a href="https://rabbijohnrosove.blog/category/human-rights/">Human rights</a> (57)
</li>
	<li class="cat-item cat-item-65178885"><a href="https://rabbijohnrosove.blog/category/inuyim-prayer-reflections-and-ruminations/">Inuyim &#8211; Prayer reflections and ruminations</a> (95)
</li>
	<li class="cat-item cat-item-698292"><a href="https://rabbijohnrosove.blog/category/israel-and-palestine/">Israel and Palestine</a> (358)
</li>
	<li class="cat-item cat-item-741786"><a href="https://rabbijohnrosove.blog/category/israelzionism/">Israel/Zionism</a> (502)
</li>
	<li class="cat-item cat-item-168299"><a href="https://rabbijohnrosove.blog/category/jewish-history/">Jewish History</a> (441)
</li>
	<li class="cat-item cat-item-379108"><a href="https://rabbijohnrosove.blog/category/jewish-identity/">Jewish Identity</a> (372)
</li>
	<li class="cat-item cat-item-7847001"><a href="https://rabbijohnrosove.blog/category/jewish-christian-relations/">Jewish-Christian Relations</a> (51)
</li>
	<li class="cat-item cat-item-264916685"><a href="https://rabbijohnrosove.blog/category/jewish-islamic-relations/">Jewish-Islamic Relations</a> (57)
</li>
	<li class="cat-item cat-item-94780"><a href="https://rabbijohnrosove.blog/category/life-cycle/">Life Cycle</a> (53)
</li>
	<li class="cat-item cat-item-61125721"><a href="https://rabbijohnrosove.blog/category/musings-about-godfaithreligious-life/">Musings about God/Faith/Religious life</a> (190)
</li>
	<li class="cat-item cat-item-422"><a href="https://rabbijohnrosove.blog/category/poetry/">Poetry</a> (86)
</li>
	<li class="cat-item cat-item-18129"><a href="https://rabbijohnrosove.blog/category/quote-of-the-day/">Quote of the Day</a> (101)
</li>
	<li class="cat-item cat-item-2282"><a href="https://rabbijohnrosove.blog/category/social-justice/">Social Justice</a> (355)
</li>
	<li class="cat-item cat-item-955"><a href="https://rabbijohnrosove.blog/category/stories/">Stories</a> (74)
</li>
	<li class="cat-item cat-item-9305"><a href="https://rabbijohnrosove.blog/category/tributes/">Tributes</a> (30)
</li>
	<li class="cat-item cat-item-1"><a href="https://rabbijohnrosove.blog/category/uncategorized/">Uncategorized</a> (566)
</li>
	<li class="cat-item cat-item-98215"><a href="https://rabbijohnrosove.blog/category/womens-rights/">Women&#039;s Rights</a> (152)
</li>
			</ul>

			</aside><aside id="linkcat-1356" class="sidebar-widget widget_links"><h1 class="widget-title">Blogroll</h1>
	<ul class='xoxo blogroll'>
<li><a href="http://www.peacenow.org">Americans for Peace Now</a></li>
<li><a href="http://www.arza.org">Association of Reform Zionists of America (ARZA)</a></li>
<li><a href="http://www.d-noam.org/">Congregation Darchei Noam</a></li>
<li><a href="http://www.haaretz.com">Haaretz</a></li>
<li><a href="http://www.jstreet.org">J Street</a></li>
<li><a href="http://www.jpost.com">Jerusalem Post</a></li>
<li><a href="http://www.jpost.com/JerusalemReport/Home.aspx">Jerusalem Report</a></li>
<li><a href="http://www.kbyonline.org/mevasseret_zion/index.html">Kehillat Mevesseret Zion</a></li>
<li><a href="http://www.tioh.org">Temple Israel of Hollywood</a></li>
<li><a href="http://www.irac.org">The IRAC</a></li>
<li><a href="http://www.forward.com">The Jewish Daily Forward</a></li>
<li><a href="http://www.jewishjournal.com">The LA Jewish Journal</a></li>
<li><a href="http://www.rac.org">The RAC</a></li>
<li><a href="http://www.urj.org">URJ</a></li>
<li><a href="http://www.wupj.org/">World Union for Progressive Judaism</a></li>

	</ul>
</aside>

	</div><!-- #secondary .widget-area -->


		</div><!-- end #main -->
	</div><!-- end #page-inner -->

	<footer id="colophon" role="contentinfo">
		<div id="footer">
			<div id="footer-inner">
				<div id="footer-inner-inner">
					

				</div><!-- end #footer-inner-inner -->
			</div><!-- end #footer-inner -->
		</div>
		<div id="copyright">
			<div id="copyright-inner">
					<div id="copyright-inner-inner">
					<p>
						<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
							</p>
				</div><!-- end #copyright-inner-inner -->
			</div><!-- end #copyright-inner -->
		</div><!-- end #copyright -->
	</footer><!-- end #footer -->

	<!--  -->
<script type="text/javascript">
	window._tkq = window._tkq || [];
	if ( Math.random() < 0.01 ) {
		window._tkq.push( [
			'recordEvent',
			'wpcom_wordads_noad',
			{"theme":"pub\/chateau","blog_id":25064604,"post_id":8722,"reason_orange":1,"reason_noadverts_plugin":1,"reason_upgrade":1,"reason_blog_safe":1,"reason_post_null":1}
		] );
	}
</script><script src='//0.gravatar.com/js/gprofiles.js?ver=202231z' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-d6d23bf2d0e53f17f18290a2646cdd94">
	</div>
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/rabbijohnrosove.wordpress.com\/public.api\/connect\/?action=request&domain=rabbijohnrosove.blog","logoutURL":"https:\/\/rabbijohnrosove.wordpress.com\/wp-login.php?action=logout&_wpnonce=ddfdb85406","homeURL":"https:\/\/rabbijohnrosove.blog\/","postID":"8722","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/textarea-autosize.min.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1649873911j'></script>
	<div id="actionbar" style="display: none;"
			class="actnbr-pub-chateau actnbr-has-follow">
		<ul>
								<li class="actnbr-btn actnbr-hidden">
								<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
							<div class="actnbr-popover tip tip-top-left actnbr-notice" id="follow-bubble">
							<div class="tip-arrow"></div>
							<div class="tip-inner actnbr-follow-bubble">
															<ul>
											<li class="actnbr-sitename">
			<a href="https://rabbijohnrosove.blog">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Rabbi John Rosove&#039;s Blog			</a>
		</li>
										<form method="post" action="https://subscribe.wordpress.com" accept-charset="utf-8" style="display: none;">
																						<div class="actnbr-follow-count">Join 346 other followers</div>
																					<div>
										<input type="email" name="email" placeholder="Enter your email address" class="actnbr-email-field" aria-label="Enter your email address" />
										</div>
										<input type="hidden" name="action" value="subscribe" />
										<input type="hidden" name="blog_id" value="25064604" />
										<input type="hidden" name="source" value="https://rabbijohnrosove.blog/2022/07/31/my-favorite-podcasts/" />
										<input type="hidden" name="sub-type" value="actionbar-follow" />
										<input type="hidden" id="_wpnonce" name="_wpnonce" value="32a3a112a1" />										<div class="actnbr-button-wrap">
											<button type="submit" value="Sign me up">
												Sign me up											</button>
										</div>
									</form>
									<li class="actnbr-login-nudge">
										<div>
											Already have a WordPress.com account? <a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frabbijohnrosove.blog%252F2022%252F07%252F31%252Fmy-favorite-podcasts%252F">Log in now.</a>										</div>
									</li>
								</ul>
															</div>
						</div>
					</li>
							<li class="actnbr-ellipsis actnbr-hidden">
				<svg class="gridicon gridicons-ellipsis" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M7 12c0 1.104-.896 2-2 2s-2-.896-2-2 .896-2 2-2 2 .896 2 2zm12-2c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2zm-7 0c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2z"/></g></svg>				<div class="actnbr-popover tip tip-top-left actnbr-more">
					<div class="tip-arrow"></div>
					<div class="tip-inner">
						<ul>
									<li class="actnbr-sitename">
			<a href="https://rabbijohnrosove.blog">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Rabbi John Rosove&#039;s Blog			</a>
		</li>
								<li class="actnbr-folded-customize">
								<a href="https://rabbijohnrosove.wordpress.com/wp-admin/customize.php?url=https%3A%2F%2Frabbijohnrosove.wordpress.com%2F2022%2F07%2F31%2Fmy-favorite-podcasts%2F">
									<svg class="gridicon gridicons-customize" height="20" width="20" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M2 6c0-1.505.78-3.08 2-4 0 .845.69 2 2 2 1.657 0 3 1.343 3 3 0 .386-.08.752-.212 1.09.74.594 1.476 1.19 2.19 1.81L8.9 11.98c-.62-.716-1.214-1.454-1.807-2.192C6.753 9.92 6.387 10 6 10c-2.21 0-4-1.79-4-4zm12.152 6.848l1.34-1.34c.607.304 1.283.492 2.008.492 2.485 0 4.5-2.015 4.5-4.5 0-.725-.188-1.4-.493-2.007L18 9l-2-2 3.507-3.507C18.9 3.188 18.225 3 17.5 3 15.015 3 13 5.015 13 7.5c0 .725.188 1.4.493 2.007L3 20l2 2 6.848-6.848c1.885 1.928 3.874 3.753 5.977 5.45l1.425 1.148 1.5-1.5-1.15-1.425c-1.695-2.103-3.52-4.092-5.448-5.977z"/></g></svg>									<span>Customize</span>
								</a>
							</li>
																<li class="actnbr-folded-follow">
												<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
										</li>
																	<li class="actnbr-signup"><a href="https://wordpress.com/start/">Sign up</a></li>
									<li class="actnbr-login"><a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frabbijohnrosove.blog%252F2022%252F07%252F31%252Fmy-favorite-podcasts%252F">Log in</a></li>
																	<li class="actnbr-shortlink"><a href="https://wp.me/p1HarO-2gG">Copy shortlink</a></li>
																	<li class="flb-report"><a href="http://en.wordpress.com/abuse/">Report this content</a></li>
																	<li class="actnbr-reader">
										<a href="https://wordpress.com/read/blogs/25064604/posts/8722">
											View post in Reader										</a>
									</li>
																	<li class="actnbr-subs">
										<a href="https://subscribe.wordpress.com/">Manage subscriptions</a>
									</li>
																		<li class="actnbr-fold"><a href="">Collapse this bar</a></li>
															</ul>
					</div>
				</div>
			</li>
		</ul>
	</div>
	
<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210915";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20220329";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/rabbijohnrosove.blog\/2022\/07\/31\/my-favorite-podcasts\/":8722};
	</script>
				<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jUsOwjAMBS9EalABqQvEUVBITOs2SYOd8Lk9FlIRq65sed48wzMbN6eCqcAo4PFBDvOrGWUDfyhWk0PtKQkEmlDgXrHiYJMPyEuYkgvVK9QiN8eoomHM4d1ESiuN1is3V8sQrRRk3Uxh6yZZkyaSiMW0zRYu+vl3uPE37FfcPIvmgiUGGSxT6pep0jmedsdD17Zdt2/HD/sXak0='></script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20220105#ver=20220105&amp;origin=https://rabbijohnrosove.blog' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>

		<script src="//stats.wp.com/w.js?63" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'25064604','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'25064604','v':'wpcom','tz':'0','user_id':'0','post':'8722','subd':'rabbijohnrosove'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE0/bU8yQkx3RTR3RmZTSndoTltKYUswZV1ZRHlESzhMQVNFMD1IWmQuSkhmTzhXYVYwc1FKPUp2cHxUaXxmT01pRnkyNF1PUmpHPW5TU1s9Umw5Tmg3RmMrNnR+P2hBV1d3NFJicTQmW0xCQ0dbbj1+SytkLnUxK1p3bVBmbDk9S3B0SXpfU0plVkozJj9FT3RzVFdqaTdrLDEyLCYxdXw1Vlt1NUFDeEYxRE44cV1bYTBwfkNxQTlQWm1iZD1FWFt5bnlfYVFHXW0vZ1UtW3lQJTZhVGhVeFV+Mnl5LGREK0tkQWZia2otWHNDVF9xa0llPTJTRy9NYUssWWouX09SYUF2WmdmeWJmUkM0OVhIemZhYTQsYlosViVGQj1TN1hHLmxFZ3BPWS8vWX5TUQ=='}]);
_stq.push([ 'clickTrackerInit', '25064604', '8722' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></div><!-- end #page -->
</body>
</html>
